Bioware Archive V2 > Hordes of the Underdark Official Campaign

Henchmen attacking during cutscene

<< < (3/3)

Legacy_HipMaestro:


               Empyre65 wrote...
What I did was, after completing the undead quest and two island quests, I cleared out the beholder caves, but avoided the final room with the queen, and almost completed the mind flayers quest, avoiding the last room. Then I went into town and did my final shopping and then finished both those areas before returning to town for the battle. I didn't have to do any teleporting. Did I break something without knowing it?
--- End quote ---
No.  As long as you have already completed both of the island quests and can avoid the City Core it can be done.  I prefer to keep the Duergar merchant available as long as possible to sell off all the loot from the last few areas so usually finish the Maker last... just an economic decision on my part since the djinni's buy ceiling is so low. But I do like to have the ability to pick and choose how I want to finish the sequence.

But I use the same method as you do except for always completing the Strange Town quest first.  Then follow the rest to just before completion of each to amass enough gold to pay for full weapon upgrades before using the black pearl, hopping back and forth via bindings to redeem loot with Rizolvir, who seems to be the best buyer.

Apologies for straying far OT.  There is a lot of saving in Chpater 2 for me, though.  I save at least 3 times during the final battle because the game stalls for me some times after the courtyard battle and then after the Valsharess battle. Nothing really seems to help there for me so i assume it is my crap vcard or perhaps driver.
               
               

               
            

Legacy_jmlzemaggo:


               That battle gets kind of slow for me too... as far as my memory serves its only purpose: me.
               
               

               
            

Legacy_Kolbarten:


               Well, first I would like to point out that my game is already patched to 1.69, so patching probably is not the issue.

Second, it seems that the problem started earlier, on chapter 2, but I found a partial solution.

I was about to enter Vixtra's lair, then Sodalis appeared to give his usual speech. But this time, he didn't appeared at all. Not even his voice or speech. Then the animation ended, and Sodalis was there fully buffed, but my text box indicated that he gave his speech, even though i didn't saw or heard it. After many frustrated strategies to see the animation as it should be, I asked Nathyrra to cast Improved Invisibility om me and her, and gave passive follow order. This time, Sodalis appeared and gave his speech as usual, although he was transparent, like he was invisible or hiding. So maybe the problem has something to do with the opponent turning hostile before the intended time.

I tried to find the procedures to reset factions on the forum, but couldn't find it. Could you please point me the post, or at least where else can I find this procedure?
               
               

               
            

Legacy_HipMaestro:


               Kolbarten wrote...
I tried to find the procedures to reset factions on the forum, but couldn't find it. Could you please point me the post, or at least where else can I find this procedure?
--- End quote ---
I use to know how to do it with the Chooser in the DM Client but forgot.  You can experiment with it much as I had if you like. I seldom have used it myself except to locate certain items in the current game.  A l-o-o-o-n-g time ago.

However, you can use the console command ## dm_setfaction <faction name>
where <faction name> can be hostile, defender, merchant, commoner or pc
Note: <merchant> should work fine for henchmen since that is their default faction.  BTW, ignore the delineating brackets when typing in the names.

Once you've typed the command & faction and pressed [ENTER], you'll get a target cursor which needs to be clicked onto the NPC which is hostile.  If you are paused, you can change all the NPCs you want (by retyping the same command, targeting & clicking each) then exit Debug mode and play with the modified setting.

This will only work if the NPC has truly gone hostile (red), though.  Otherwise, your toon must get killed and respawn to reset the factions back into their original reputation relationship (at least it works this way in the OC).  This second situation (the non-red one) can occur if your PC accidentally attacks a henchman while it is not a member of your party.  It won't turn red but will attack your PC.  In some environments, you can just kill them and resurrect them but this dynamic varies from content to content.

TBH, though, your description of the anomaly above would cause me to re-install the entire shebang.  It seems very funky to me and I have never read about anything as bizarre as this occurring on anyone else's game.  But you would know better than I if it is that annoying.
               
               

               
                     Modifié par HipMaestro, 01 février 2012 - 11:01 .
                     
                  
            

Legacy_Kolbarten:


               Well, following the tip that it could be an error on the install CD, I uninstalled it and installed using a different CD. Luckily I have two (one was for me and the other for my sister, but she prefers easier, turn-based RPGs). This time, the genie merchant didn't tried to punch me, my henchman stood still during the cutscenes, and I managed to talk with Mephistopheles before slicing him with Enserric.

So it looks like it was really a broken install CD after all. Thanks for the help and tips of everyone.
               
               

               
            

Navigation

[0] Message Index

[*] Previous page

Go to full version