Author Topic: Strange skidding bug using keyboard movement when stopping  (Read 786 times)

Legacy_WiredWraith

  • Jr. Member
  • **
  • Posts: 62
  • Karma: +0/-0


               

I'm using the NWN Diamond Edition from GOG with the latest patch (1.69).  When I run in Driving camera Mode (or any other camera mode actually) using the keyboard (WASD) my character will sometimes skid when stopping, putting his hands up momentarily while doing it as if to fight.  It's very annoying because I have to wait for this brief animation to stop before I can turn causing a little lag, about 1 second.  This doesn't happen at all when using mouse click movement, just with the keyboard (which I prefer). What's causing this, and is there a fix?  Thanks for any help.



               
               

               
            

Legacy_KMdS!

  • Sr. Member
  • ****
  • Posts: 364
  • Karma: +0/-0
Strange skidding bug using keyboard movement when stopping
« Reply #1 on: May 15, 2016, 07:43:42 am »


               

There may be no "fix" for this. When using the keyboard, you can move your pc whether you are connecting to the server or not. When using a mouse, you will not move if you are not actually connecting to the server. I may be mistaken as I have not had to think about this for a very long time.



               
               

               
            

Legacy_AndrueD

  • Sr. Member
  • ****
  • Posts: 253
  • Karma: +0/-0
Strange skidding bug using keyboard movement when stopping
« Reply #2 on: May 15, 2016, 01:02:26 pm »


               

I never try drive camera so wonder how u use all radial icon with keyboard only? Mayb set hootkeys? Must use mouse for find the target, right?  Wen goog to find guide that show how to use keyboard for all NWN action, no link ever show up.



               
               

               
            

Legacy_WiredWraith

  • Jr. Member
  • **
  • Posts: 62
  • Karma: +0/-0
Strange skidding bug using keyboard movement when stopping
« Reply #3 on: May 15, 2016, 05:21:45 pm »


               

Thanks for the replies, boys.  Well, I was hoping to play NWN in a zoomed-in, behind the character, 3rd person perspective to give it a bit of a new, fresh look (played many NWN with modules a few years ago but only in zoomed-out isometric) but this looks look a deal-breaker for me. I was being chased by Giant Spiders in a module I played recently, and was managing to outrun them, until I went to turn, and my character decides to do his little skidding "put your dukes up" animation before turning.  Result: horrible poison death from behind.  Oh, well. 



               
               

               
            

Legacy_WiredWraith

  • Jr. Member
  • **
  • Posts: 62
  • Karma: +0/-0
Strange skidding bug using keyboard movement when stopping
« Reply #4 on: May 15, 2016, 05:26:25 pm »


               


I never try drive camera so wonder how u use all radial icon with keyboard only? Mayb set hootkeys? Must use mouse for find the target, right?  Wen goog to find guide that show how to use keyboard for all NWN action, no link ever show up.




 


I use my left hand for WASD keyboard movement/running and my mouse is controlled with my right hand.  It would've been a perfect control scheme for me but, alas, it was not to be.


               
               

               
            

Legacy_KMdS!

  • Sr. Member
  • ****
  • Posts: 364
  • Karma: +0/-0
Strange skidding bug using keyboard movement when stopping
« Reply #5 on: May 15, 2016, 06:53:37 pm »


               

As the grey matter begins working old machinery.......creaks and groans within my mind, lol


 


What happened most likely is that the slide happened because the client was out of sync with the server. There client will give its best estimate of where you are in the world, but if for some reason there is a latency issue between the server and client, the servers update will provide the client the actual location on the server and the client will slide you to the correct location. The "put up your dukes" animation ran because there had actually been an interaction between your pc and the spider that was not registered by the client at the moment if happened because of the latency issue. Your client updated you to the proper state on receiving the server update.....plainly put, there was lag. Nothing else.



               
               

               
            

Legacy_WiredWraith

  • Jr. Member
  • **
  • Posts: 62
  • Karma: +0/-0
Strange skidding bug using keyboard movement when stopping
« Reply #6 on: May 15, 2016, 07:40:24 pm »


               

The thing is I really want to get back into playing NWN again with a huge list of modules I put together that I missed the last time I played NWN extensively (about 8-10 years ago) but I want a new way of looking at it.  I now have a i5 processor with a good GPU and a decent 1920x1080 gaming monitor and quite frankly NWN looks great on it with all details maxed.  But in the past it's always been the same old top down boring isometric view for me, and now that I can see the remarkable detail on those pillows on the bed, or the studs on the chests, I want to actually- well,  see them, like, all the time...in close to first person perspective.  Just too frustrating to be moving around in 3rd person so smoothly only to have that random and very jarring lag occur when I go to turn or maneuver.  And it can be deadly in encounters.  Arrrghhh.  However, I've loved this game so much I may just suffer isometric and play it like the old days, but as a last resort.



               
               

               
            

Legacy_AndrueD

  • Sr. Member
  • ****
  • Posts: 253
  • Karma: +0/-0
Strange skidding bug using keyboard movement when stopping
« Reply #7 on: May 16, 2016, 01:03:36 am »


               

Hmm... wonder if u have any secur app running or mayb virus protect to add more lag.  Wen I forget to disable, i get very much jump even wit mousemove.  Sometime I go very far on area but look at small map where my locate is way behind.  Then sudden jump where I see many creature spawn at same place that not there b4 were I stand.   Wen I use wasd, it always act slower then mouse but only use keys wen very tite corner.


 


Have tried this on many server?  Mayb try plain no-hak server to see if resource making more lag or not.  Am thinking reason you see skid so clear cuz are zoom down more close then seen with top vue.  I never see skid like you say but do see jumpin specialy wen lots of ppl spawn encounter all over server at same time.


 


U see skid wen play SP in drive camera too?



               
               

               
            

Legacy_Failed.Bard

  • Hero Member
  • *****
  • Posts: 1409
  • Karma: +0/-0
Strange skidding bug using keyboard movement when stopping
« Reply #8 on: May 16, 2016, 04:23:18 am »


               

  It can happen due to an animation playing when movement is started as well.  When the movement ends, the animation that was interrupted tries to finish.


 


  I would guess you aren't seeing it with the mouse movement because that might not start until after the animation is finished, at least in the case of the non-looping ones.



               
               

               
            

Legacy_WiredWraith

  • Jr. Member
  • **
  • Posts: 62
  • Karma: +0/-0
Strange skidding bug using keyboard movement when stopping
« Reply #9 on: May 16, 2016, 06:49:10 am »


               


Hmm... wonder if u have any secur app running or mayb virus protect to add more lag.  Wen I forget to disable, i get very much jump even wit mousemove.  Sometime I go very far on area but look at small map where my locate is way behind.  Then sudden jump where I see many creature spawn at same place that not there b4 were I stand.   Wen I use wasd, it always act slower then mouse but only use keys wen very tite corner.


 


Have tried this on many server?  Mayb try plain no-hak server to see if resource making more lag or not.  Am thinking reason you see skid so clear cuz are zoom down more close then seen with top vue.  I never see skid like you say but do see jumpin specialy wen lots of ppl spawn encounter all over server at same time.


 


U see skid wen play SP in drive camera too?




 


I already tried all the steps mentioned above.  No joy.  I tried different versions of NWN with the expansions.  I even tried a different mouse/keyboard in case it was my gaming input devices causing issues, and disconnected my Xbox 360 wireless dongle.  Nothing works.  As someone stated earlier, it's a server sync issue, I think.   Everyone probably has this "bug."  It only becomes a problem if you use the WASD keyboard for movement exclusively.  Unfortunately this is exactly what I needed to do to get a decent & smooth approximation of 3rd person camera from behind the player character like more modern RPGs.


               
               

               
            

Legacy_WiredWraith

  • Jr. Member
  • **
  • Posts: 62
  • Karma: +0/-0
Strange skidding bug using keyboard movement when stopping
« Reply #10 on: May 16, 2016, 06:51:13 am »


               


  It can happen due to an animation playing when movement is started as well.  When the movement ends, the animation that was interrupted tries to finish.


 


  I would guess you aren't seeing it with the mouse movement because that might not start until after the animation is finished, at least in the case of the non-looping ones.




 


So no solution to this problem exists?  Bummer.


               
               

               
            

Legacy_CaveGnome

  • Sr. Member
  • ****
  • Posts: 432
  • Karma: +0/-0
Strange skidding bug using keyboard movement when stopping
« Reply #11 on: May 18, 2016, 07:23:03 pm »


               

As you play with the keyboard, perhaps ratcheting up the key repeat speed can help. Usually, there are 2 or 3 options for that in the BIOS/Setup of your computer. First, press DEL or the appropriate key (F1... depends of your rig) just after switching on your computer to enter the SETUP. Look for the "Boot Settings Config" menu or equivalent. There is something named "Typematic Rate Setting", enable it. Now Select the max number in "Typematic Rate (Chars/Sec)", usually you can't go higher than 30. Now go to "Typematic Delay (Msec)" and choose the shortest time available (between keystrokes), usually it is 250 ms. Save and Exit your Setup, done. Let us know if this works.


 


CG


 


Edit: you may be interested '<img'> in the most excellent improved camera mod made by Sawark (easy to find at the neverwintervault.org) .



               
               

               
            

Legacy_WiredWraith

  • Jr. Member
  • **
  • Posts: 62
  • Karma: +0/-0
Strange skidding bug using keyboard movement when stopping
« Reply #12 on: May 19, 2016, 01:24:52 pm »


               


As you play with the keyboard, perhaps ratcheting up the key repeat speed can help. Usually, there are 2 or 3 options for that in the BIOS/Setup of your computer. First, press DEL or the appropriate key (F1... depends of your rig) just after switching on your computer to enter the SETUP. Look for the "Boot Settings Config" menu or equivalent. There is something named "Typematic Rate Setting", enable it. Now Select the max number in "Typematic Rate (Chars/Sec)", usually you can't go higher than 30. Now go to "Typematic Delay (Msec)" and choose the shortest time available (between keystrokes), usually it is 250 ms. Save and Exit your Setup, done. Let us know if this works.


 


CG


 


Edit: you may be interested '<img'> in the most excellent improved camera mod made by Sawark (easy to find at the neverwintervault.org) .




 


Hmm, interesting approach to the problem.  Unfortunately, I couldn't find the "Typematic Rate Setting" in my motherboard's BIOS (Asus P8Z77-V PRO) and I looked everywhere, in every nested nook and advanced cranny . Maybe someone else that has the same issue would be willing to try.  I'd really like to know if there's a solution to this.  Thanks for your help.


               
               

               
            

Legacy_CaveGnome

  • Sr. Member
  • ****
  • Posts: 432
  • Karma: +0/-0
Strange skidding bug using keyboard movement when stopping
« Reply #13 on: May 19, 2016, 08:59:51 pm »


               

Hmm, interesting approach to the problem.  Unfortunately, I couldn't find the "Typematic Rate Setting" in my motherboard's BIOS (Asus P8Z77-V PRO) and I looked everywhere, in every nested nook and advanced cranny . Maybe someone else that has the same issue would be willing to try.  I'd really like to know if there's a solution to this.  Thanks for your help.




I just downloaded P8Z77-V Pro manual. It seems you are right... No keyboard settings in the BIOS :-( These were standard options  for years and years. Maybe modern uefi bios don't need then or someone decided it was out of fashion to tune keyboards... Or these functions are now hiden in special keyboard software drivers. Hmm... {puzzled gnome scratching his head}.
               
               

               
            

Legacy_AndrueD

  • Sr. Member
  • ****
  • Posts: 253
  • Karma: +0/-0
Strange skidding bug using keyboard movement when stopping
« Reply #14 on: May 20, 2016, 01:28:01 am »


               

Dunno if this help or no.  My key set already fast for rate. It set like pic show not all way to short.  Mayb move all way to short help with drive camera?